最新消息:本站所有跳转向bbs.ykit.cn的附件将全面停止,附件已转移到https://www.qingsj.com

discourse论坛,第一节:安装discourse需升级docker到最新版

discourse论坛 有客 1599浏览 0评论

想要成功安装discourse,你还需要看下面几篇文章。

都是有客搭建过程中记录,希望能够帮助到你们!

discourse论坛,第一节:安装discourse需升级docker到最新版

discourse论坛,安装方法,第二节:discourse内存设置

discourse论坛,安装方法,第三节:discourse详细安装方法

有客在安装discourse论坛时遇到很多问题,

现在有客安装成功,将方法分享给大家,希望能够帮助到各位朋友!

有不懂的地方,可以留言,大家一起讨论.

有客用的是阿里的乌班图环境,点击进入

如果直接使用阿里的这个乌班图环境,会出现各种问题,原因是Docker版本太低!

下面我们来升级Docker,

sudo apt-get install apt-transport-https  
# Add the Docker repository key to your local keychain 不需要复制到命令行执行 
sudo apt-key adv --keyserver keyserver.ubuntu.com --recv-keys 36A1D7869245C8950F966E92D8576A8BA88D21E9  
# Add the Docker repository to your apt sources list. 不需要复制到命令行执行 
sudo sh -c "echo deb https://get.docker.io/ubuntu docker main > /etc/apt/sources.list.d/docker.list"  
# update your sources list 不需要复制到命令行执行 
sudo apt-get update  

# 之后通过下面命令来安装最新版本的docker:  
apt-get install -y lxc-docker  
# 以后更新则:  
apt-get update -y lxc-docker  

ln -sf /usr/bin/docker /usr/local/bin/docker

按照这个做法,我试了一下 更新的时候出错,所以不行!所以我最后一步执行的是
官方论坛的朋友给出的答案:

apt-get upgrade lxc-docker

最后升级成功:

0e8d8026aa5fc530

查看升级后的版本:

docker version

转载请注明:有客帮 » discourse论坛,第一节:安装discourse需升级docker到最新版

发表我的评论
取消评论
表情

Hi,您需要填写昵称和邮箱!

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址